using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!php/const:?\s*([a-zA-Z\\_]+(::[a-zA-Z_]+)?)+(:\s*(.*))?";
string substitution = @"%const($1)$3";
string input = @"parameters:
class_constant: !php/const Symplify\ConfigTransformer\Tests\Converter\ConfigFormatConverter\YamlToPhp\YamlToPhpTest::TEST
class: !php/const Symplify\ConfigTransformer\Tests\Converter\ConfigFormatConverter\YamlToPhp\YamlToPhpTest::class
class2: !php/const:Symplify\ConfigTransformer\Tests\Converter\ConfigFormatConverter\YamlToPhp\YamlToPhpTest::class
const: !php/const PHP_INT_MAX
const2: !php/const:PHP_INT_MAX
unexisting_constant: !php/const SomeClass::Constant
!php/const PHP_INT_MAX: some_value
!php/const App\Entity\Plant::TRANSITION_PLANT: some_value
!php/const:App\Entity\Plant::TRANSITION_TWO: some_value";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}