using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!----------).*\n)+(?=----------$)";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
test
----------
User 1 said the following:
Magna fermentum iaculis eu non diam phasellus vestibulum lorem. Lectus quam id leo in vitae turpis massa sed elementum. Ut consequat semper viverra nam libero. Libero justo laoreet sit amet cursus sit amet.
----------
User 2 said the following:
Magna fermentum iaculis eu non diam phasellus vestibulum lorem. Lectus quam id leo in vitae turpis massa sed elementum. Ut consequat semper viverra nam libero. Libero justo laoreet sit amet cursus sit amet.";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}