const regex = /^(?:(?!----------).*\n)+(?=----------$)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!----------).*\\n)+(?=----------$)', 'm')
const str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
test
----------
User 1 said the following:
Magna fermentum iaculis eu non diam phasellus vestibulum lorem. Lectus quam id leo in vitae turpis massa sed elementum. Ut consequat semper viverra nam libero. Libero justo laoreet sit amet cursus sit amet.
----------
User 2 said the following:
Magna fermentum iaculis eu non diam phasellus vestibulum lorem. Lectus quam id leo in vitae turpis massa sed elementum. Ut consequat semper viverra nam libero. Libero justo laoreet sit amet cursus sit amet.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}