import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!----------).*\\n)+(?=----------$)";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.\n\n"
+ "test\n\n"
+ "----------\n"
+ "User 1 said the following:\n\n"
+ "Magna fermentum iaculis eu non diam phasellus vestibulum lorem. Lectus quam id leo in vitae turpis massa sed elementum. Ut consequat semper viverra nam libero. Libero justo laoreet sit amet cursus sit amet.\n\n\n"
+ "----------\n"
+ "User 2 said the following:\n\n"
+ "Magna fermentum iaculis eu non diam phasellus vestibulum lorem. Lectus quam id leo in vitae turpis massa sed elementum. Ut consequat semper viverra nam libero. Libero justo laoreet sit amet cursus sit amet.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}