const regex = /(.*NSRL(.*:.\D*\d*).*µg\/day)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*NSRL(.*:.\\D*\\d*).*µg\\\/day)', 'gm')
const str = `FOR INHALATION AND ORAL ROUTES : NSRL - Oral: 6.4 µg/day and MADL - Oral : 24 µg/day NSRL - Inhalation: 13 µg/day and MADL - Inhalation: 49 µg/day Only if concentration of this substance is higher than the safe harbor level (ingredient or impurity) : This product can expose you to chemicals including [name of one or more chemicals], which is [are] known to the State of California to cause [cancer] and [birth defects or other reproductive harm]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}