const regex = /^(?:кубик)(\s[1-6])?$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:кубик)(\\s[1-6])?$', 'igm')
const str = `кубик
кубик 1
кубик 2
кубик 3
кубик 4
кубик 5
кубик 6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}