$re = '/^(?:кубик)(\s[1-6])?$/im';
$str = 'кубик
кубик 1
кубик 2
кубик 3
кубик 4
кубик 5
кубик 6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);