re = /^(?:кубик)(\s[1-6])?$/im
str = 'кубик
кубик 1
кубик 2
кубик 3
кубик 4
кубик 5
кубик 6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end