const regex = /\[(collapse|collapse in)\]\s*<(h[2-4])>(.*)<\/\2>(.*)\s*\[\/collapse\]/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(collapse|collapse in)\\]\\s*<(h[2-4])>(.*)<\\\/\\2>(.*)\\s*\\[\\\/collapse\\]', 'sg')
const str = `<p>Bene eros jus neo olim pecus suscipit. </p>
[collapse in]   
      <h2>titel</h2>
<p>Illum iriure neo populus refoveo.</p> 
      <h3>titel</h3>
<p>Illum iriure neo populus refoveo.</p> 
      <h2>titel</h>
<p>Illum iriure neo populus refoveo.</p> 
[/collapse]
[collapse]   
      <h3>titel2</h3>
<p>Illum iriure neo populus refoveo.</p>  [/collapse]`;
const subst = `<\2 data-target="#\3" data-toggle="\1">\3</\2>\n<div id="\3" class="collapse">\4</div>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);