const regex = /(\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w)', 'gm')
const str = `Is there a way to do a find and replace (regex) all uppercase characters in the matching strings with lowercase ones? Preferably in VS Code or IntelliJ I already have my regex ready.`;
const subst = `\L\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);