$re = '/(\w)/m';
$str = 'Is there a way to do a find and replace (regex) all uppercase characters in the matching strings with lowercase ones? Preferably in VS Code or IntelliJ I already have my regex ready.';
$subst = "\L\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;