use strict;
my $str = 'Is there a way to do a find and replace (regex) all uppercase characters in the matching strings with lowercase ones? Preferably in VS Code or IntelliJ I already have my regex ready.';
my $regex = qr/(\w)/mp;
my $subst = '\\L\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";