#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\bGET\s\/).+?(?=[\s\n])"
Local $sString = "GET /docs/index.html HTTP/1.1" & @CRLF & _
"Host: www.nowhere123.com" & @CRLF & _
"Accept: image/gif, image/jpeg, */*" & @CRLF & _
"Accept-Language: en-us" & @CRLF & _
"Accept-Encoding: gzip, deflate" & @CRLF & _
"User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)" & @CRLF & _
"(blank line)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")