import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\bGET\\s\\/).+?(?=[\\s\\n])";
final String string = "GET /docs/index.html HTTP/1.1\n"
+ "Host: www.nowhere123.com\n"
+ "Accept: image/gif, image/jpeg, */*\n"
+ "Accept-Language: en-us\n"
+ "Accept-Encoding: gzip, deflate\n"
+ "User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)\n"
+ "(blank line)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}