re = /(?<=\bGET\s\/).+?(?=[\s\n])/
str = 'GET /docs/index.html HTTP/1.1
Host: www.nowhere123.com
Accept: image/gif, image/jpeg, */*
Accept-Language: en-us
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
(blank line)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end