#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([[:alnum:]-]+\.(?>de|com|net|org))\b"
Local $sString = "||p5.focus.de/img/fotos/*/banner*.jpg$image" & @CRLF & _
"||apis.google.com/js/plusone.js$script" & @CRLF & _
"||mobilbranche.de/wp-content/themes/mobilbranche_2014/lib/img/mobilbranche_bg1.gif$image" & @CRLF & _
"||connect.facebook.net^$script" & @CRLF & _
"||a.bf-tools.net^$script" & @CRLF & _
"www1.wdr.de##.socialMedia" & @CRLF & _
"praxistipps.focus.de##.fb-wrap.fb-direction-row.fb-col-12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")