const regex = /([[:alnum:]-]+\.(?>de|com|net|org))\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([[:alnum:]-]+\\.(?>de|com|net|org))\\b', 'gm')
const str = `||p5.focus.de/img/fotos/*/banner*.jpg\$image
||apis.google.com/js/plusone.js\$script
||mobilbranche.de/wp-content/themes/mobilbranche_2014/lib/img/mobilbranche_bg1.gif\$image
||connect.facebook.net^\$script
||a.bf-tools.net^\$script
www1.wdr.de##.socialMedia
praxistipps.focus.de##.fb-wrap.fb-direction-row.fb-col-12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}