re = /([[:alnum:]-]+\.(?>de|com|net|org))\b/m
str = '||p5.focus.de/img/fotos/*/banner*.jpg$image
||apis.google.com/js/plusone.js$script
||mobilbranche.de/wp-content/themes/mobilbranche_2014/lib/img/mobilbranche_bg1.gif$image
||connect.facebook.net^$script
||a.bf-tools.net^$script
www1.wdr.de##.socialMedia
praxistipps.focus.de##.fb-wrap.fb-direction-row.fb-col-12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end