#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)E(\d+)\.tiff?$"
Local $sString = "D_Passaic_F01_NBR_E0003.tif" & @CRLF & _
"D_Passaic_F01_NBR_Eabcd.tif" & @CRLF & _
"D_Passaic_F01_NBR_1234.tif" & @CRLF & _
"D_abcd_E1234.tif" & @CRLF & _
"E_abcd_E1234.tif"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")