$re = '/E(\d+)\.tiff?$/m';
$str = 'D_Passaic_F01_NBR_E0003.tif
D_Passaic_F01_NBR_Eabcd.tif
D_Passaic_F01_NBR_1234.tif
D_abcd_E1234.tif
E_abcd_E1234.tif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);