package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)E(\d+)\.tiff?$`)
var str = `D_Passaic_F01_NBR_E0003.tif
D_Passaic_F01_NBR_Eabcd.tif
D_Passaic_F01_NBR_1234.tif
D_abcd_E1234.tif
E_abcd_E1234.tif`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}