import re
regex = re.compile(r"(?<=(?<![^\W\d_])[.,!?()-])(?=[^\W\d_])|(?<=[^\W\d_])(?=[.,!?()-](?![^\W\d_]))", flags=re.MULTILINE)
test_str = "!hello 77e! - -world-view- world-view"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)