using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[(\[][^()\[\]]*?text[^()\[\]]*[)\]]";
string input = @" [filler dontmatch filler] ( filler text filler)
( filler text filler) [filler dontmatch filler] ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}