package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[(\[][^()\[\]]*?text[^()\[\]]*[)\]]`)
var str = ` [filler dontmatch filler] ( filler text filler)
( filler text filler) [filler dontmatch filler] `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}