$re = '/[(\[][^()\[\]]*?text[^()\[\]]*[)\]]/m';
$str = ' [filler dontmatch filler] ( filler text filler)
( filler text filler) [filler dontmatch filler] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);