use strict;
my $str = 'Today is 06/19/2023. The meeting is scheduled for 07-05-2023. The number is 1234567890. 6.3.23';
my $regex = qr/[0-9](?:[[:punct:]\d]*[0-9])?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}