import Foundation
let pattern = #"[0-9](?:[[:punct:]\d]*[0-9])?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Today is 06/19/2023. The meeting is scheduled for 07-05-2023. The number is 1234567890. 6.3.23"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)