re = /[0-9](?:[[:punct:]\d]*[0-9])?/
str = 'Today is 06/19/2023. The meeting is scheduled for 07-05-2023. The number is 1234567890. 6.3.23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end