using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bname ID:(?!.*\bname ID:)\s*(\S+)";
string input = @"name ID: andy country name: china city name: beijing name ID: john country name: thailand city name: bangkok";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}