re = /\bname ID:(?!.*\bname ID:)\s*(\S+)/
str = 'name ID: andy country name: china city name: beijing name ID: john country name: thailand city name: bangkok'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end