$re = '/\bname ID:(?!.*\bname ID:)\s*(\S+)/';
$str = 'name ID: andy country name: china city name: beijing name ID: john country name: thailand city name: bangkok';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);