use strict;
my $str = '## Markdown Syntax {#markdown-syntax}\\n\\n (lorem ipsum test).\\n\\n## Headers {#headers}\\n\\n function HelloCodeTitle(props) {return <h1>Hello, {props.name}</h1>; } {2}';
my $regex = qr/{.*?}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}