$re = '/{.*?}/m';
$str = '## Markdown Syntax {#markdown-syntax}\\n\\n (lorem ipsum test).\\n\\n## Headers {#headers}\\n\\n function HelloCodeTitle(props) {return <h1>Hello, {props.name}</h1>; } {2}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);