// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m){.*?}").unwrap();
let string = "## Markdown Syntax {#markdown-syntax}\\n\\n (lorem ipsum test).\\n\\n## Headers {#headers}\\n\\n function HelloCodeTitle(props) {return <h1>Hello, {props.name}</h1>; } {2}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}