use strict;
my $str = '<div class="product-faq-content"><div class="product-faq-block product-faq-block--left">
<ul class="product-faq-list">
<li class="product-faq-item">
<p class="product-faq-title"></p>
<div class="product-faq-container">
<p class="product-faq-text"><br><br>
<br><br>
<br><br>
</p><br>
<table class="cgv-table">
<thead class="cgv-table-head">
<th></th>
<th class="cgv-table-cell--head"></th>
<th class="cgv-table-cell--head"></th>
<th class="cgv-table-cell--head"></th>
</thead>
<tbody>
<tr class="cgv-table-row">
<td class="cgv-table-cell">
<p class="cgv-table-title"></p>
</td>
<td class="cgv-table-cell">
</td>
<td class="cgv-table-cell">{{XXXXXXXXXXXX}}
</td>
<td class="cgv-table-cell">{{XXXXXXXXXXXX}}
</td>
</tr>
<tr class="cgv-table-row">
<td class="cgv-table-cell">
<p class="cgv-table-title">
</p>
</td>
<td class="cgv-table-cell"></td>
<td class="cgv-table-cell"></td><td class="cgv-table-cell"></td></tr><tr class="cgv-table-row"><td class="cgv-table-cell"><p class="cgv-table-title">{{XXXXXXXXXXXX}}
</p>
</td><td class="cgv-table-cell">{{XXXXXXXXXXXX}}
</td>
<td class="cgv-table-cell">{{XXXXXXXXXXXX}}
</td>
<td class="cgv-table-cell">{{XXXXXXXXXXXX}}
</td>
</tr>
</tbody>
</table>
</div>
</li>
<li class="product-faq-item">
<p class="product-faq-title">{{XXXXXXXXXXXX}}</p>
<div class="product-faq-container">
<p class="product-faq-text">{{XXXXXXXXXXXX}}<br>
{{XXXXXXXXXXXX}}
</p>
</div>
</li>
<li class="product-faq-item">
<p class="product-faq-title">{{XXXXXXXXXXXX}}</p>
<div class="product-faq-container">
<p class="product-faq-text">{{XXXXXXXXXXXX}}</p>
</div>
</li>
</div>';
my $regex = qr/([<][^br][^<]*[>])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}