// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([<][^br][^<]*[>])").unwrap();
let string = "<div class=\"product-faq-content\"><div class=\"product-faq-block product-faq-block--left\">
<ul class=\"product-faq-list\">
<li class=\"product-faq-item\">
<p class=\"product-faq-title\"></p>
<div class=\"product-faq-container\">
<p class=\"product-faq-text\"><br><br>
<br><br>
<br><br>
</p><br>
<table class=\"cgv-table\">
<thead class=\"cgv-table-head\">
<th></th>
<th class=\"cgv-table-cell--head\"></th>
<th class=\"cgv-table-cell--head\"></th>
<th class=\"cgv-table-cell--head\"></th>
</thead>
<tbody>
<tr class=\"cgv-table-row\">
<td class=\"cgv-table-cell\">
<p class=\"cgv-table-title\"></p>
</td>
<td class=\"cgv-table-cell\">
</td>
<td class=\"cgv-table-cell\">{{XXXXXXXXXXXX}}
</td>
<td class=\"cgv-table-cell\">{{XXXXXXXXXXXX}}
</td>
</tr>
<tr class=\"cgv-table-row\">
<td class=\"cgv-table-cell\">
<p class=\"cgv-table-title\">
</p>
</td>
<td class=\"cgv-table-cell\"></td>
<td class=\"cgv-table-cell\"></td><td class=\"cgv-table-cell\"></td></tr><tr class=\"cgv-table-row\"><td class=\"cgv-table-cell\"><p class=\"cgv-table-title\">{{XXXXXXXXXXXX}}
</p>
</td><td class=\"cgv-table-cell\">{{XXXXXXXXXXXX}}
</td>
<td class=\"cgv-table-cell\">{{XXXXXXXXXXXX}}
</td>
<td class=\"cgv-table-cell\">{{XXXXXXXXXXXX}}
</td>
</tr>
</tbody>
</table>
</div>
</li>
<li class=\"product-faq-item\">
<p class=\"product-faq-title\">{{XXXXXXXXXXXX}}</p>
<div class=\"product-faq-container\">
<p class=\"product-faq-text\">{{XXXXXXXXXXXX}}<br>
{{XXXXXXXXXXXX}}
</p>
</div>
</li>
<li class=\"product-faq-item\">
<p class=\"product-faq-title\">{{XXXXXXXXXXXX}}</p>
<div class=\"product-faq-container\">
<p class=\"product-faq-text\">{{XXXXXXXXXXXX}}</p>
</div>
</li>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}