import Foundation
let pattern = #"([<][^br][^<]*[>])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="product-faq-content"><div class="product-faq-block product-faq-block--left">
<ul class="product-faq-list">
<li class="product-faq-item">
<p class="product-faq-title"></p>
<div class="product-faq-container">
<p class="product-faq-text"><br><br>
<br><br>
<br><br>
</p><br>
<table class="cgv-table">
<thead class="cgv-table-head">
<th></th>
<th class="cgv-table-cell--head"></th>
<th class="cgv-table-cell--head"></th>
<th class="cgv-table-cell--head"></th>
</thead>
<tbody>
<tr class="cgv-table-row">
<td class="cgv-table-cell">
<p class="cgv-table-title"></p>
</td>
<td class="cgv-table-cell">
</td>
<td class="cgv-table-cell">{{XXXXXXXXXXXX}}
</td>
<td class="cgv-table-cell">{{XXXXXXXXXXXX}}
</td>
</tr>
<tr class="cgv-table-row">
<td class="cgv-table-cell">
<p class="cgv-table-title">
</p>
</td>
<td class="cgv-table-cell"></td>
<td class="cgv-table-cell"></td><td class="cgv-table-cell"></td></tr><tr class="cgv-table-row"><td class="cgv-table-cell"><p class="cgv-table-title">{{XXXXXXXXXXXX}}
</p>
</td><td class="cgv-table-cell">{{XXXXXXXXXXXX}}
</td>
<td class="cgv-table-cell">{{XXXXXXXXXXXX}}
</td>
<td class="cgv-table-cell">{{XXXXXXXXXXXX}}
</td>
</tr>
</tbody>
</table>
</div>
</li>
<li class="product-faq-item">
<p class="product-faq-title">{{XXXXXXXXXXXX}}</p>
<div class="product-faq-container">
<p class="product-faq-text">{{XXXXXXXXXXXX}}<br>
{{XXXXXXXXXXXX}}
</p>
</div>
</li>
<li class="product-faq-item">
<p class="product-faq-title">{{XXXXXXXXXXXX}}</p>
<div class="product-faq-container">
<p class="product-faq-text">{{XXXXXXXXXXXX}}</p>
</div>
</li>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)