$re = '/\S*[^a-z \'-]\S* | \S*[^a-z \'-]\S*/i';
$str = 'This is a? #test a e3ample test';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;