// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\S*[^a-z '-]\S* | \S*[^a-z '-]\S*").unwrap();
let string = "This is a? #test a e3ample test";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}