re = /\S*[^a-z '-]\S* | \S*[^a-z '-]\S*/i
str = 'This is a? #test a e3ample test'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result