import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{11,12}$)(?=\\S* \\S*$)0[ 1-9][ \\d]+$";
final String string = "01123 456789\n"
+ "01123467 890\n"
+ "0112367 890\n\n"
+ "012367 890\n"
+ "011 23 456789\n"
+ "011 234567 890\n"
+ "0012 4567890\n"
+ "001 4567890\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}