$re = '/^(?=.{11,12}$)(?=\S* \S*$)0[ 1-9][ \d]+$/m';
$str = '01123 456789
01123467 890
0112367 890
012367 890
011 23 456789
011 234567 890
0012 4567890
001 4567890
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);