use strict;
my $str = '01123 456789
01123467 890
0112367 890
012367 890
011 23 456789
011 234567 890
0012 4567890
001 4567890
';
my $regex = qr/^(?=.{11,12}$)(?=\S* \S*$)0[ 1-9][ \d]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}