import re
regex = re.compile(r"^(\d+\s+,)\s*,\s*$", flags=re.MULTILINE)
test_str = ("id, day_model,night_model\n"
"=========================== \n"
"1 , , \n"
"2 ,2_DAY , \n"
"3 ,3_DAY ,3_NIGHT \n"
"4 , , \n"
"5 , ,2_Day")
subst = "\\1false,false"
result = regex.sub(subst, test_str)
if result:
print(result)