// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+\s+,)\s*,\s*$").unwrap();
let string = "id, day_model,night_model
===========================
1 , ,
2 ,2_DAY ,
3 ,3_DAY ,3_NIGHT
4 , ,
5 , ,2_Day";
let substitution = "\\1false,false";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}