re = /^(\d+\s+,)\s*,\s*$/m
str = 'id, day_model,night_model
===========================
1 , ,
2 ,2_DAY ,
3 ,3_DAY ,3_NIGHT
4 , ,
5 , ,2_Day'
subst = '\\1false,false'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result