package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#[^\s,]+`)
var str = `fghdkf jdfhgj #hjghg jfhgjf djfghdfkjg
gjdfh dfhgkfj #gkjh,#jgkjhg,#jghk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}