re = /#[^\s,]+/
str = 'fghdkf jdfhgj #hjghg jfhgjf djfghdfkjg
gjdfh dfhgkfj #gkjh,#jgkjhg,#jghk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end