$re = '/#[^\s,]+/';
$str = 'fghdkf jdfhgj #hjghg jfhgjf djfghdfkjg
gjdfh dfhgkfj #gkjh,#jgkjhg,#jghk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);