package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bB\w{4}r\b`)
var str = `"Butter is good Buffer"
"I love Butter"
"Where my Butter is?"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}